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The WeMoSat — A weather monitoring mini-satellite
The WeMoSat is a miniature satellite that can be used to
/ \ monitor local weather conditions like temperature,
pressure, humidity etc of your own local area. It also
gives the altitude of the satellite. It is a low cost, easy to
assemble satellite and uses open-source software.

BMP280
Battery

,\-\v 7. The WeMoSat uses NodeMCU ESP8266 micro controller

D at its heart and two sensors BMP 280 and DHT11. The

—— programming is done in Arduino IDE. Open-source

\ / libraries and codes are used to program the WeMoSat.

Features of WeMoSat

1. WeMoSat is an extremely simplified version of a real satellite which can be used as a hands-on
tool to learn about real satellites and to have a practical experience of a real space project.

2.  The WeMoSat is similar to an actual weather satellite and contains many of the major subsystems
found in an actual satellite like controller, sensors, communication system and power. Actual
satellites have additional control mechanisms and advanced sensors.

3. Participants will learn all aspects of designing a satellite: selecting its mission, integrating the
components, testing, deployment and then analyzing the data.

4. WeMoSat maps real-time atmospheric parameters like temperature, pressure, humidity and
transmits it wirelessly to a ground station.

5. This data is then displayed in graphical format on a webpage so that students can easily
comprehend it.

Major Components of WeMoSat

NodeMCU ESP 8266: 32-bit Microcontroller with Web Server

3.3v cP2102 1 Input Voltage : 4,5V-10V
R S 2. PC/ Laptop connection: Micro USB
(GPI02) Fash 3. Digital 1/O Pins : 11 Digital and 1 Analog
Button
4, Programming: Arduino IDE

Module g micro USB

Connector
WiFi Antenna

BMP 280: Temperature and Pressure Sensor

Operating Voltage: Typically, 3.3V

-40 to +85°C Temperature with +1°C accuracy

300 to 1100 hPa Pressure with £0.12 hPa accuracy
+9000m to -500m Height with £1m accuracy

- Filter Gapacitor
*5MP250 Sansor

« Pull-down Resistor

call A\

1. 3 to 5V input power
2. 20-80% humidity readings with 5% accuracy
3. 0-50°C temperature readings +2°C accuracy

Humidity Sensing
Component

/

/ / NICTemeperature Sensor
/ Thermistor




Appendix: Installation of software and libraries

Installing the Arduino Software (IDE)

o]

-

Wi, Check the components you want to install and uncheck the companents
you don't want to install. Click Mext to continue.

[ Install Arduino software
Install USB driver

Create Start Menu shortcut
Create Desktop shortout
Assodate .ino files

Select components to install:

Space required: 392. 7MB

Cancel < Back Next >

@ Arduino Setup: Installation Felder - x
Setup will install Arduina in the following folder. To install in a different

&) folder, dick Browse and select another folder. Click Install to start the
installation.

Destination Folder

Browse...

Space required: 392.7MB
Space available: 24.6GB

Cancel < Back Install

Installing CH340 USB driver (if not available):

B DriverSetup(X64)

Device Driver Install / UnlInstall

Select INF |CH3!I1SER.INF

| WGH.CH
IHSTALL
|__ USB-SERIAL CH3h4B8

|__ ©68/08/26014, 3.4._201)
UNINSTALL

HELP

Get the latest version from the download page. You
can choose between the Installer (.exe) and the Zip
packages. Select the Installer version as that installs
directly everything you need to use the Arduino
Software (IDE), including the drivers.

When the download finishes, proceed with the
installation and please allow the driver installation
process when you get a warning from the operating
system.

Choose all the components to install.

Choose the installation directory. The process will
extract and install all the required files to execute
properly the Arduino Software (IDE)

Download CH341SER.exe from Google search and
run the executable.

CH341SER (EXE)

Click the "Uninstall" button first. Then click on the
"Install" button.

Windows CH340 Driver Installation


https://www.arduino.cc/en/Main/Software
https://cdn.sparkfun.com/assets/learn_tutorials/8/4/4/CH341SER.EXE
https://cdn.sparkfun.com/assets/learn_tutorials/8/4/4/CH341SER.EXE
https://docs.arduino.cc/static/33f20406f68c5707052471d78a90a5c6/9cb4e/DRV_Capture1.png
https://docs.arduino.cc/static/12311f50263afe3f12349d932fdeb3f5/9cb4e/DRV_Capture2.png
https://cdn.sparkfun.com/assets/learn_tutorials/8/4/4/CH340-Win10_Uninstall-Install.PNG

Installing the ESP8266 Core on Windows OS

Preferences ﬂh.
Sketchbook location:
C:\sers\Sam\Documents\Arduing
Editor language: System Default -
Editor font size: 12
Interface scale: Automatic | 100 % (requires restart of Arduina)

Show verbose output during: [~ compilation [ upload
Compiler warnings: Nane -

[7] Display line numbers

[] Enable Code Folding

verify code after upload

[7] Use external editor

Agaressively cache compiled core

Check for updates on startup

Update sketch files to new extension on save (,pde -> .ino)
Save when verifying or uploading

Additional Boards Manager URLs: |6.com/stable fpackage_esp8266com_index. json

C:\Users\Shree\AppDatall ocal Arduino 15\preferences. bt
anly when Arduino is not running)
Cancel
Boards Manager =)
Type (Ml ~ | lespa2es
esp8266 by ESP8266 Community e

Boards included in this package:

Generic ESPB266 Module, Generic EPB285 Module, ESPDUinG (ESP-13 Module), Adafruit Feather HUZZAH,
ESPrasso Lite 1.0, ESPrasso Lite 2.0, Phosnix 1.0, Phosnix 2.0, NlodeMCU 0.3 (ESP-12 Moduls), NodeMCU 1.0
Module, Olimex MOD-WIFI-ESPE266(-DEV), SparkFun ESPB266 Thing, SparkFun ESPE26E Thing Dev, SweetPea,
LOLIN(WEMOS) D1 R2 & mini, LOLIN(WEMOS) D1 mini Pro, LOLIN{WEMOS) D1 mini Lite, WeMos D1 R1,ESPino,
ThaiEasyElec's ESPina, Wiflnfo, Arduina, 4D Systems gand IoD Range, Digistump Oak, WiFiduino, Sezed Wia
Link.

Online help

Mare info.

SN

Installing the BMP280 and DHT11 libraries

Al ~
Adafrult BIAP230 Library by
Aiat

¥ for B

y lon EM

INSTALL
pin connected to the BT se

Let’s proceed with installing ESP8266 Arduino core.
To begin, we'll need to update the board manager
with a custom URL. Open up Arduino IDE and go
to File > Preferences. Then, copy below URL into
the Additional Board Manager URLstext box
situated on the bottom of the window and Hit OK.

http://arduino.esp8266.com/stable/package esp
8266com _index.json

Then navigate to the Board Manager by going to
Tools > Boards > Boards Manager. There should be
a couple new entries in addition to the standard
Arduino boards. Filter your search by typing
esp8266. Click on that entry and select Install.

The board definitions and tools may take a few
minutes to download and install). Once the
installation has completed, a small INSTALLED text
will appear next to the entry. You can now close the
Board Manager.

To run the programs for the pressure sensor
(BMP280) and humidity sensor (DHT11), you need
to download and install their respective libraries

From Arduino, open Library Manager. It will be in
Tools Menu (or left pane menu, as shown in fig.) for
2.x version and under Sketch -> Include Library
Menu for 1.x old versions.

Search BMP280 and install Adafruit BMP280 library
with all dependencies and then search DHT11 and
Install DHT11 Sensor Library from Adafruit.


http://arduino.esp8266.com/stable/package_esp8266com_index.json
http://arduino.esp8266.com/stable/package_esp8266com_index.json

Arduino Example: Blink

To make sure ESP8266 Arduino core and the NodeMCU are properly set up, we’ll upload the simplest
sketch of all — The Blink! We will use the on-board LED for this test. As mentioned earlier in this tutorial,
DO pin of the board is connected to on-board Blue LED & is user programmable. Perfect!

@ sketch_aug07a | Arduino 1.8.5 = | B -ﬁ-‘
File Edit Sketch Help
Auto Format CunkeT -
Archive Sketch N
sketeh_augd7i gy Encoding & Reload T

setup ()
// put your

Ctrl+ Shift+M
Ctrls Shift+L

Seral Meritor Generic ESP8266 Module

Generic ESPE285 Module
ESPDuino (ESP-13 Module)
Adafruit Feather HUZZAH ESP8266
ESPresso Lite 1.0

ESPresso Lite 2.0

Phoenix1.0

Phoenix 2.0

Serial Plotter

} WiFil01 Firmware Updater

loopl) {
/ put your,

Board: "Arduino/Genuina Uno” )
Port |
} Get Board Info

Programmer; "AVRISP midl" '
Burn Bootloader
NodeMCU 1.0 (ESP-12E Module)
Olimex MOD-WIFI-ESPB266(-DEV)
SparkFun ESPE266 Thing
SparkFun ESPE266 Thing Dev
SweetPea ESP-210
WeMos D1 R2 & mini

v

NodeMCU 0.9 (ESP-12 Module)

| Blink | Arduino 185

:E&i

File Edit Sketch Help
Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload
Serial Monitor Ctrl+Shift+M

e Serial Plotter Ctrl+Shift=| | °F Power the &

d s=tup()
initiali WiFiL01 Firmware Updater

} Board: "ESP32 Dev Module” 4
Flash Mode: "QIO" 4
Flash Size: "4MB (32Mb)" e
Partition Scheme: "Default” ¥ on (HIGH is ti
Flash Frequency: "80MHz" L3 55:?1
PSRAM: "Disabled” »E::;;I —
Upload Speed: "115200" » *
Core Debug Level: "None” L4
Port Y Serial ports
Get Board Info COMS3
Programmer: "AVRISP midl" 4
Burn Bootloader
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Before we get to uploading sketch & playing with
LED, we need to make sure that the board is
selected properly in Arduino IDE. Open Arduino
IDE and select NodeMCU 0.9 (ESP-12
Module) option under your Arduino IDE > Tools >
Board menu.

Now, plug your ESP8266 NodeMCU into your
computer via micro-B USB cable. Once the board
is plugged in, it should be assigned a unique COM

port. On Windows machines, this will be
something  like COM#, and on  Mac/Linux
computers it will come in the form

of /dev/tty.usbserial-XXXXXX. Select this serial
port under the Arduino IDE > Tools > Port menu.
Also select the Upload Speed : 115200
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9.

Instructions Sheet for opening webpage to display WeMoSat data on a mobile / laptop:
Create a Wi-Fi network or hotspot with following details:

a.

b.

C.
Install

a.

SSID: wemosat
Password: wemosat123

This may be done by starting hotspot on mobile and renaming hotspot — Fig 1

the App “Network Analyser” on your mobile phone.
https://play.google.com/store/apps/details?id=net.techet.netanalyzerlite.an&hl=en IN&gl=US

Turn ON the power switch on the WeMoSat

a.

When you do this an LED on the microcontroller (this is the biggest component on the WeMoSat)
should blink and DHT11 LED will be glow. That indicates power is proper.

Open the Network Analyzer App on mobile where you created the WeMoSat hotspot

a.
b.
c.

d.

Click the LAN Scan tab and Check for Espressif Inc in the list displayed — Fig 2

Check and note or copy IP Address of the Expressif Inc

Note: Sometimes the Espressif may not be displayed so you have to select an IP from the list using
your own sense. There willbe a W, P below the IP address of WeMoSat toindicate that the address
is both ping ready and has a webpage attached to it. IP address will be like 192.168.xx.xxx

For laptop / desktop, open command prompt and type > arp -a to get the IP address

Paste the IP address in any browser in the mobile phone- Fig 3
To check results on laptop, connect the Wi-Fi of the laptop to ssid: wemosat with password:
wemosat123 and type the above IP address in browser.

a.

Any device on which you want to open the IP address must be connected to the same network to
which WeMoSat is connected i.e ssid: wemosat and password wemosat123

You can connect another mobile or laptop or desktop.

Students if they have mobile with them can all likewise connect to same network and open the IP
address in the browser

The browser will update every 5s with the temperature, pressure, humidity and altitude data
To change some data, you can blow air from your mouth on to the blue sensor which will

increa
a.
b.

se the humidity and increase the temperature if it is cold.

You can also blow on to the other brown sensor to increase temperature
Lift the entire WeMoSat up to change altitude.

i.  You can use any convenient method to raise height of the WeMoSat

ii. Geta student to go to higher floor or tie a thread and pull up the WeMoSat etc
Switch OFF the WeMoSat when the demo is over.

Wi-Fi hotspot

Hotspot name

wemosat

Advanced
Tum
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Fig 1: Hotspot Fig 2: Net Analyzer Fig 3: WeMoSat Data in browser


https://play.google.com/store/apps/details?id=net.techet.netanalyzerlite.an&hl=en_IN&gl=US

Space Talk Series
Satellites, Rockets and More

Build WeMoSat - a mini-satellite
The first step to a real satellite

Build a small Telescope
The Time Machine to see Universe

Vivruti team conducts these fun and learn programs on space science and
engineering in schools which is willing to arrange the programs. Students from
4th standard to 9th standard are eligible to participate. As an exception, we will
do programs for a groups of children if they are in Pune, Nasik or Ahmedabad
provided there are more than 10 children interested and they are willing to host
the program. Mail or message us for further details.

Email: satish@vivruti.com
Web: www.vivruti.com

(((%))) WhatsApp: 8849131823
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